Many early adopter Xoom customers are voicing issues with their tablets not offering the popular YouTube app.

Motorola’s Owner Forums and various other sources show that the issue has been reported since the Xoom launched. Today, I ran into it, too.

Watching YouTube videos via the Android 3.0 browser works even without the application.

Motorola and Google have showcased the native YouTube app many times to demo how polished and stylish their new tablet OS really is. With the app not being available, a fun part of the user experience is gone for fresh Xoom users.

Before jumping right into a non-official fix, here is what all Xoom users reporting the problem experience:

  • Right after the initial setup, there is no icon for the YouTube app.
  • The Google “Books” app icon shows up. Tapping it yields an “Application is not installed.” error.
  • In Settings > Applications > Manage applications > All the “Books” app has a size of 0.00B and version 3.0.1-110420. It cannot be uninstalled. The “YouTube” app in the same menu reports an 8.00KB size and version 3.0.15. Uninstall is not available, either.
  • Most of the users reporting the problem purchased their Xooms from Costco.

Multiple factory resets do not help, nor does reinstalling YouTube from the Android Market.

In fact, the latter makes things even worse. Turns out, the Android Market is not aware about the full new version of the YouTube app for Android tablets. It compares the version reported by the Xoom with it’s own list of known versions for smartphones and (wrongly!) offers an “update”.

Neither Motorola, nor Google have officially responded, yet.

An unofficial fix – and as always, you do this at your own risk – is as follows:

  1. In Settings > Applications turn on Unknown sources.
  2. Open Browser on the device and do a Google search for youtube 2.1.6 apk. Unfortunately, we are not allowed to directly link to the file, but it’s pretty easy to find anyway.
  3. Download and install the file.
  4. Once installed, do not run it!
  5. Reboot your Xoom.
  6. After reboot, you should see the YouTube icon in Apps > All.
  7. A quick check in Settings > Applications > Manage applications > All > YouTube should verify, it’s really version 3.0.15 that came back.

I can confirm, this worked for me.

One more thing: Admittedly, I am a huge Apple fan, mostly using an iPad 2. My professional life forced me to check out the Xoom.

While I’m really surprised with the usability and performance of Honeycomb, it’s these kind of low-level problems, that ruin almost the entire experience for me.

Do you own the Motorola Xoom? Did you run into any of these problems? Let us know in the comments!