<!DOCTYPE html>
<html itemscope itemtype="https://schema.org/" lang="en-us" prefix="fb:http://ogp.me/ns/fb# og:http://ogp.me/ns#">
    <head>
    <title>Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed | The Next Web</title>
    <meta charset="utf-8">
    <meta content="text/html; charset=UTF-8" http-equiv="content-type">
    <meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible">
    <meta name="viewport" content="initial-scale=1,maximum-scale=1,user-scalable=no,width=device-width">
    <meta name="referrer" content="unsafe-url">
    <meta name="apple-mobile-web-app-title" content="The Next Web">
    <meta name="msvalidate.01" content="EBA9DC0DD4E376AF9708F73323680AB1">
    <meta name="viewport" content="width=device-width,initial-scale=1,shrink-to-fit=no">

    <link rel="dns-prefetch" href="//cdn0.tnwcdn.com/">
    <link rel="dns-prefetch" href="//www.googletagmanager.com">
    <link rel="preconnect" href="//cdn0.tnwcdn.com/">
    <link rel="preconnect" href="//www.googletagmanager.com">
    <link rel="manifest" href="/manifest.json">

    <!-- Icons -->
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-57x57.png?v=1510743095" sizes="57x57">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-60x60.png?v=1510743095" sizes="60x60">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-72x72.png?v=1510743095" sizes="72x72">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-76x76.png?v=1510743095" sizes="76x76">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-114x114.png?v=1510743095" sizes="114x114">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-120x120.png?v=1510743095" sizes="120x120">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-144x144.png?v=1510743095" sizes="144x144">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-152x152.png?v=1510743095" sizes="152x152">
    <link rel="apple-touch-icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/apple-touch-icon-180x180.png?v=1510743095" sizes="180x180">
    <link rel="icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/favicon-16x16.png?v=1510743095" sizes="16x16" type="image/png">
    <link rel="icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/favicon-32x32.png?v=1510743095" sizes="32x32" type="image/png">
    <link rel="icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/favicon-96x96.png?v=1510743095" sizes="96x96" type="image/png">
    <link rel="icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/favicon-194x194.png?v=1510743095" sizes="194x194" type="image/png">
    <link rel="icon" ref="https://cdn0.tnwcdn.com/wp-content/themes/cyberdelia/assets/icons/android-chrome-192x192.png?v=1510743095" sizes="192x192" type="image/png">
    <link rel="shortcut icon" ref="/sub-brand/hardfork.ico">
    <meta name="apple-mobile-web-app-title" content="HardFork">
    <meta name="application-name" content="HardFork">
    <meta name="theme-color" content="#660099">



    <!-- SEO & Social -->
    <link href="https://thenextweb.com/hardfork/2018/04/13/1118548" rel="canonical">
    <meta name="author" content="Neer Varshney">
    <meta name="description" content="Zerocoin has a &#039;denial of service&#039; bug that allows for attackers to burn honest users&#039; Coins. This fact has been known for almost two months now, but remains unfixed.">
    <meta name="original-source" content="https://thenextweb.com/hardfork/2018/04/13/1118548">
    <meta name="article:author" content="HardFork">
    
    <meta name="article:published" content="2018-04-13">
    <meta name="article:modified" content="2018-04-13">
    
    <meta name="article:published_time" content="2018-04-13T14:24:38+00:00">
    <meta name="article:modified_time" content="2018-04-13T15:01:17+00:00">

    <link href="https://plus.google.com/+TheNextWeb" rel="publisher">
    <meta name="yandex-verification" content="66df89eec58f9170">
    <meta name="article:publisher" content="https://www.facebook.com/thenextweb">

    <meta property="og:description" content="Zerocoin has a &#039;denial of service&#039; bug that allows for attackers to burn honest users&#039; Coins. This fact has been known for almost two months now, but remains unfixed.">
    <meta property="og:updated_time" content="2018-04-13T15:01:17+00:00">
    <meta property="og:title" content="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed">
    <meta property="og:url" content="https://thenextweb.com/hardfork/2018/04/13/1118548">

    <meta property="og:locale" content="en_US">
    <meta property="og:type" content="article">
    <meta property="og:site_name" content="HardFork">

    <meta property="fb:pages" content="106976563522">
    <meta property="fb:pages" content="136548879865026">
    <meta property="fb:pages" content="252857631761065">
    <meta property="fb:pages" content="665773266831844">


    <meta property="fb:app_id" content="378011798897423">
    <meta property="og:image:width" content="1140" />
    <meta property="og:image:height" content="650" />

    <meta property="og:image" content="https://img-cdn.tnwcdn.com/image/hardfork?filter_last=1&fit=1280%2C640&url=https%3A%2F%2Fcdn0.tnwcdn.com%2Fwp-content%2Fblogs.dir%2F1%2Ffiles%2F2018%2F04%2FZCoin.png&expires=17291625950&signature=1765b61635bfdeb29fb07302cc406f1c">
    <meta property="og:image:secure_url" content="https://img-cdn.tnwcdn.com/image/hardfork?filter_last=1&fit=1280%2C640&url=https%3A%2F%2Fcdn0.tnwcdn.com%2Fwp-content%2Fblogs.dir%2F1%2Ffiles%2F2018%2F04%2FZCoin.png&expires=17291625950&signature=1765b61635bfdeb29fb07302cc406f1c">
    <meta property="twitter:image" content="https://img-cdn.tnwcdn.com/image/hardfork?filter_last=1&fit=1280%2C640&url=https%3A%2F%2Fcdn0.tnwcdn.com%2Fwp-content%2Fblogs.dir%2F1%2Ffiles%2F2018%2F04%2FZCoin.png&expires=17291625950&signature=1765b61635bfdeb29fb07302cc406f1c">


    <meta name="twitter:account_id" content="10876852">
    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@thenextweb">

    <meta name="twitter:title" content="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed">
    <meta name="twitter:description" content="Zerocoin has a &#039;denial of service&#039; bug that allows for attackers to burn honest users&#039; Coins. This fact has been known for almost two months now, but remains unfixed.">


    <meta name="twitter:creator" content="">

    
            <!-- JSON-LD breadcrumbs -->
        <script type="application/ld+json">{"@context":"http:\/\/schema.org","@id":"#Breadcrumb","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/thenextweb.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/thenextweb.com\/hardfork\/","name":"Hard Fork"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/thenextweb.com\/hardfork\/2018\/04\/13\/1118548\/","name":"Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed"}}]}</script>
        <!-- JSON-LD schema -->
        <script type="application/ld+json">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</script>
    </script>

    <script src="/sub-brand/assets/js/lib/modernizr-custom.js"></script>
    <link href="/sub-brand//css/genesis.css?id=b6abdf4db0d6af463fcb" rel="stylesheet" type="text/css" >
    <link href="/sub-brand//css/style.css?id=516582da6f2a6ccee41e" rel="stylesheet" type="text/css" >

    <!-- DataLayer -->
    <script type="text/javascript">
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        window.dataLayer = window.dataLayer || [];
    </script>
    <!-- TODO -->
        <script type="text/javascript">
        dataLayer.push({"page":[{"id":1118548,"url":"https:\/\/thenextweb.com\/hardfork\/2018\/04\/13\/1118548\/","words":781,"time":"2:24 pm","column":0,"fyi":0,"author":"Neer Varshney","date":"2018-04-13","date_published":"2018-04-13 14-24","date_published_week":"2018-15","type":"Article","post-status":"publish","videos":0,"tags":"","categories":"cryptocurrency,Hard Fork,Security,Tech","sections":"Tech","companies":"","profiles":"","events":"","topics":"","comments":"0","social_title":"Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed","shares":{"fb":"13","tw":"","li":"","go":"","re":""},"ads":{"roadblocked":0,"sponsor":"","sponsored":"No","client":null,"campaign_name":null,"product_type":null}}]});
    </script>
    
    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MHDDSC');</script>
    <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MHDDSC" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

    <!-- Cookie consent -->
    <script>
        var TNWCookieConsent = {
            NAME: 'tnw_consent_cookie',

            accept: function () {
                this.setCookie();
                this.hideDialog();
                return false;
            },

            hideDialog: function () {
                document.getElementsByTagName("html")[0].className = document.getElementsByTagName("html")[0].className.replace(/(?:^|\s)no-cookies(?!\S)/g, "");
            },

            init: function () {
                var cookie;
                var parts;
                var val;

                val = "; " + document.cookie;
                parts = val.split("; " + this.NAME + "=");

                if (parts.length == 1) {
                    this.showDialog();
                }
            },

            setCookie: function () {
                var exdate;
                var exdays;
                var val;

                exdays = 365;
                exdate = new Date();
                exdate.setDate(exdate.getDate() + exdays);
                val = escape("1") + ((exdays == null) ? "" : "; path=/; expires=" + exdate.toUTCString());
                document.cookie = this.NAME + "=" + val;
            },

            showDialog: function () {
                document.getElementsByTagName("html")[0].className = document.getElementsByTagName("html")[0].className += " no-cookies";
            }
        }

        TNWCookieConsent.init();

        window.checkMobile = function() {
            var check = false;
            (function(a){if(/(android|bb\d+|meego).+mobile|avantgo|bada\/|blackberry|blazer|compal|elaine|fennec|hiptop|iemobile|ip(hone|od)|iris|kindle|lge |maemo|midp|mmp|mobile.+firefox|netfront|opera m(ob|in)i|palm( os)?|phone|p(ixi|re)\/|plucker|pocket|psp|series(4|6)0|symbian|treo|up\.(browser|link)|vodafone|wap|windows ce|xda|xiino|android|ipad|playbook|silk/i.test(a)||/1207|6310|6590|3gso|4thp|50[1-6]i|770s|802s|a wa|abac|ac(er|oo|s\-)|ai(ko|rn)|al(av|ca|co)|amoi|an(ex|ny|yw)|aptu|ar(ch|go)|as(te|us)|attw|au(di|\-m|r |s )|avan|be(ck|ll|nq)|bi(lb|rd)|bl(ac|az)|br(e|v)w|bumb|bw\-(n|u)|c55\/|capi|ccwa|cdm\-|cell|chtm|cldc|cmd\-|co(mp|nd)|craw|da(it|ll|ng)|dbte|dc\-s|devi|dica|dmob|do(c|p)o|ds(12|\-d)|el(49|ai)|em(l2|ul)|er(ic|k0)|esl8|ez([4-7]0|os|wa|ze)|fetc|fly(\-|_)|g1 u|g560|gene|gf\-5|g\-mo|go(\.w|od)|gr(ad|un)|haie|hcit|hd\-(m|p|t)|hei\-|hi(pt|ta)|hp( i|ip)|hs\-c|ht(c(\-| |_|a|g|p|s|t)|tp)|hu(aw|tc)|i\-(20|go|ma)|i230|iac( |\-|\/)|ibro|idea|ig01|ikom|im1k|inno|ipaq|iris|ja(t|v)a|jbro|jemu|jigs|kddi|keji|kgt( |\/)|klon|kpt |kwc\-|kyo(c|k)|le(no|xi)|lg( g|\/(k|l|u)|50|54|\-[a-w])|libw|lynx|m1\-w|m3ga|m50\/|ma(te|ui|xo)|mc(01|21|ca)|m\-cr|me(rc|ri)|mi(o8|oa|ts)|mmef|mo(01|02|bi|de|do|t(\-| |o|v)|zz)|mt(50|p1|v )|mwbp|mywa|n10[0-2]|n20[2-3]|n30(0|2)|n50(0|2|5)|n7(0(0|1)|10)|ne((c|m)\-|on|tf|wf|wg|wt)|nok(6|i)|nzph|o2im|op(ti|wv)|oran|owg1|p800|pan(a|d|t)|pdxg|pg(13|\-([1-8]|c))|phil|pire|pl(ay|uc)|pn\-2|po(ck|rt|se)|prox|psio|pt\-g|qa\-a|qc(07|12|21|32|60|\-[2-7]|i\-)|qtek|r380|r600|raks|rim9|ro(ve|zo)|s55\/|sa(ge|ma|mm|ms|ny|va)|sc(01|h\-|oo|p\-)|sdk\/|se(c(\-|0|1)|47|mc|nd|ri)|sgh\-|shar|sie(\-|m)|sk\-0|sl(45|id)|sm(al|ar|b3|it|t5)|so(ft|ny)|sp(01|h\-|v\-|v )|sy(01|mb)|t2(18|50)|t6(00|10|18)|ta(gt|lk)|tcl\-|tdg\-|tel(i|m)|tim\-|t\-mo|to(pl|sh)|ts(70|m\-|m3|m5)|tx\-9|up(\.b|g1|si)|utst|v400|v750|veri|vi(rg|te)|vk(40|5[0-3]|\-v)|vm40|voda|vulc|vx(52|53|60|61|70|80|81|83|85|98)|w3c(\-| )|webc|whit|wi(g |nc|nw)|wmlb|wonu|x700|yas\-|your|zeto|zte\-/i.test(a.substr(0,4))) check = true;})(navigator.userAgent||navigator.vendor||window.opera);
            return check;
        };
        window.IS_MOBILE = checkMobile();
    </script>
</head>
    <body class="p-channel p-channel--hardfork" data-modules="post|stream">
        <nav class="c-nav" id="nav">
    <div class="c-nav-mobile">
        
        <div class="c-nav-mobile-wrapper">
            <div class="c-nav-mobile-property">
                <h6>TNW News</h6>
                <ul>
                    <li><a href="https://thenextweb.com/latest">Latest</a></li>
                    <li><a href="https://thenextweb.com/insights">Insights</a></li>
                    <li><a href="https://thenextweb.com/hardfork" class="is-active">Hard Fork</a></li>
                    <li><a href="https://thenextweb.com/full-stack">Full Stack</a></li>
                    <li><a href="https://thenextweb.com/investing-2-0">Investing 2.0</a></li>
                    <li><a href="https://thenextweb.com/distract">Distract</a></li>
                </ul>
            </div>
            <div class="c-nav-mobile-tnw">
                <h6>More TNW</h6>
                <ul class="c-nav-tnw-properties">
                    <li><a href="https://thenextweb.com/">News</a></li>
                    <li><a href="https://thenextweb.com/conference">Events</a></li>
                    <li><a href="https://thenextweb.com/x">Enterprise</a></li>
                    <li><a href="https://index.co/">Intelligence</a></li>
                    <li><a href="https://answers.thenextweb.com/">Answers</a></li>
                    <li><a href="https://tq.co/">Spaces</a></li>
                </ul>
                <h6>About TNW</h6>
                <ul class="c-nav-tnw-company">
                    <li><a href="https://thenextweb.com/about">About</a></li>
                    <li><a href="https://thenextweb.com/team">Team</a></li>
                    <li><a href="https://thenextweb.com/advertise">Advertise</a></li>
                    <li><a href="https://thenextweb.homerun.co/">Jobs</a></li>
                    <li><a href="https://thenextweb.com/contact">Contact</a></li>
                </ul>
            </div>
        </div>
    </div>
    <a class="c-nav-logo" href="/">
        <svg><use xlink:href="/sub-brand/assets/img/icons.svg#tnw"></use></svg>
    </a>
    <a class="c-nav-logoChannel" href="/hardfork">
        <svg preserveAspectRatio="xMinYMin meet" viewBox="0 0 116 24" xmlns="http://www.w3.org/2000/svg">
    <path d="M8.886 4.24h4.225v15.541H8.886v-5.669H4.202v5.67H0V4.24h4.202v6.194h4.684V4.241zm14.096 0l5.625 15.541h-4.334l-.788-2.517h-4.99l-.788 2.517H13.35l5.647-15.54h3.984zm-.57 9.544l-1.4-4.487h-.044l-1.4 4.487h2.845zm15.672.613l3.523 5.384H36.77l-2.933-4.75h-.963v4.75h-4.027V4.241h6.216c3.918 0 5.669 2.32 5.669 5.516 0 2.276-.985 3.83-2.648 4.618v.022zM36.42 9.669c0-.963-.766-1.773-2.276-1.773h-1.27v3.546h1.27c1.313 0 2.276-.613 2.276-1.773zm19.24 2.364c0 4.574-2.956 7.748-7.99 7.748h-5.669V4.241h5.604c4.902 0 8.054 3.195 8.054 7.792zm-4.356 0c0-2.32-1.576-4.093-3.612-4.093h-1.664v8.142h1.358c2.363 0 3.918-1.816 3.918-4.049zm13.46-4.093h6.654v-3.7H60.736v15.541h4.028v-5.23h5.45v-3.678h-5.45V7.94zm22.74 4.071c0 4.75-3.348 7.989-8.076 7.989-4.771 0-8.076-3.261-8.076-7.989S74.657 4 79.428 4c4.728 0 8.077 3.24 8.077 8.011zm-4.355 0c0-2.276-1.51-4.115-3.72-4.115-2.19 0-3.744 1.817-3.744 4.115s1.555 4.115 3.743 4.115c2.21 0 3.721-1.817 3.721-4.115zm14.512 2.386l3.523 5.384h-4.837l-2.933-4.75h-.963v4.75h-4.027V4.241h6.216c3.918 0 5.669 2.32 5.669 5.516 0 2.276-.985 3.83-2.648 4.618v.022zm-1.664-4.728c0-.963-.766-1.773-2.276-1.773h-1.27v3.546h1.27c1.313 0 2.276-.613 2.276-1.773zm14.181-5.428a.547.547 0 0 0-.513.357l-1.99 5.395a.274.274 0 0 1-.257.18h-1.703V4.24h-4.137v15.54h4.137V13.85h3.7c.23 0 .435-.143.514-.358l1.99-5.395a.273.273 0 0 1 .257-.18h3.416V4.242h-5.414zm.643 15.54h4.771v-3.677h-4.771v3.677z" fill="#FFF" />
</svg>
    </a>
    <div class="c-nav-tnw">
        <ul class="c-nav-tnw-properties">
            <li><a href="https://thenextweb.com/">News</a></li>
            <li><a href="https://thenextweb.com/conference">Events</a></li>
            <li><a href="https://thenextweb.com/x">Enterprise</a></li>
            <li><a href="https://index.co/">Intelligence</a></li>
            <li><a href="https://answers.thenextweb.com/">Answers</a></li>
            <li><a href="https://tq.co/">Spaces</a></li>
        </ul>
        <ul class="c-nav-tnw-company">
            <li><a href="https://thenextweb.com/about">About</a></li>
            <li><a href="https://thenextweb.com/team">Team</a></li>
            <li><a href="https://thenextweb.com/advertise">Advertise</a></li>
            <li><a href="https://thenextweb.homerun.co/">Jobs</a></li>
            <li><a href="https://thenextweb.com/contact">Contact</a></li>
        </ul>
    </div>
    <div class="c-nav-property">
        <ul class="c-nav-menu">
            <li><a href="https://thenextweb.com/latest">Latest</a></li>
            <li><a href="https://thenextweb.com/insights">Insights</a></li>
            <li><a href="https://thenextweb.com/hardfork" class="is-active">Hard Fork</a></li>
            <li><a href="https://thenextweb.com/full-stack">Full Stack</a></li>
            <li><a href="https://thenextweb.com/investing-2-0">Investing 2.0</a></li>
            <li><a href="https://thenextweb.com/distract">Distract</a></li>
        </ul>
        <ul class="c-nav-icons">
            <li class="cookieConsent">
                <a href="#"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#cookie"></use></svg></a>
                <div class="cookieConsent-popOut">
                    <header>
                        <h2>Have a cookie</h2>
                    </header>
                    <main>
                    <p>
                    TNW uses cookies to personalize content and ads to
                    make our site easier for you to use.
                    We do also share that information with third parties for
                    advertising &amp; analytics.
                    </p>
                    </main>
                    <footer>
                        <button class="button button--small" onclick="TNWCookieConsent.accept();"  data-event-category="Top" data-event-action="Cookies" data-event-label="OK" data-event-non-interaction="true">Got it!</button>
                        <span>
                            or <a href="/privacy-policy/"  data-event-category="Top" data-event-action="Cookies" data-event-label="More information" data-event-non-interaction="true">More info</a>
                        </span>
                    </footer>
                </div>
            </li>
            <li class="c-nav-icons-toggleMenu">
                <a class="c-nav-toggleMenu" href="#" id="navToggleMenu">
                    <div></div>
                    <div></div>
                    <div></div>
                </a>
            </li>
        </ul>
        
    </div>
</nav>
        <div class="app">
            <div class="app-main">
                <div class="p-channel-banner">
    <div class="u-wrapper">
        <a class="p-channel-banner-logo" href="/hardfork">
            <svg preserveAspectRatio="xMinYMin meet" viewBox="0 0 116 24" xmlns="http://www.w3.org/2000/svg">
    <path d="M8.886 4.24h4.225v15.541H8.886v-5.669H4.202v5.67H0V4.24h4.202v6.194h4.684V4.241zm14.096 0l5.625 15.541h-4.334l-.788-2.517h-4.99l-.788 2.517H13.35l5.647-15.54h3.984zm-.57 9.544l-1.4-4.487h-.044l-1.4 4.487h2.845zm15.672.613l3.523 5.384H36.77l-2.933-4.75h-.963v4.75h-4.027V4.241h6.216c3.918 0 5.669 2.32 5.669 5.516 0 2.276-.985 3.83-2.648 4.618v.022zM36.42 9.669c0-.963-.766-1.773-2.276-1.773h-1.27v3.546h1.27c1.313 0 2.276-.613 2.276-1.773zm19.24 2.364c0 4.574-2.956 7.748-7.99 7.748h-5.669V4.241h5.604c4.902 0 8.054 3.195 8.054 7.792zm-4.356 0c0-2.32-1.576-4.093-3.612-4.093h-1.664v8.142h1.358c2.363 0 3.918-1.816 3.918-4.049zm13.46-4.093h6.654v-3.7H60.736v15.541h4.028v-5.23h5.45v-3.678h-5.45V7.94zm22.74 4.071c0 4.75-3.348 7.989-8.076 7.989-4.771 0-8.076-3.261-8.076-7.989S74.657 4 79.428 4c4.728 0 8.077 3.24 8.077 8.011zm-4.355 0c0-2.276-1.51-4.115-3.72-4.115-2.19 0-3.744 1.817-3.744 4.115s1.555 4.115 3.743 4.115c2.21 0 3.721-1.817 3.721-4.115zm14.512 2.386l3.523 5.384h-4.837l-2.933-4.75h-.963v4.75h-4.027V4.241h6.216c3.918 0 5.669 2.32 5.669 5.516 0 2.276-.985 3.83-2.648 4.618v.022zm-1.664-4.728c0-.963-.766-1.773-2.276-1.773h-1.27v3.546h1.27c1.313 0 2.276-.613 2.276-1.773zm14.181-5.428a.547.547 0 0 0-.513.357l-1.99 5.395a.274.274 0 0 1-.257.18h-1.703V4.24h-4.137v15.54h4.137V13.85h3.7c.23 0 .435-.143.514-.358l1.99-5.395a.273.273 0 0 1 .257-.18h3.416V4.242h-5.414zm.643 15.54h4.771v-3.677h-4.771v3.677z" fill="#FFF" />
</svg>
        </a>

                <div class="p-channel-banner-partner">
            <p>Powered by</p>
            <a href="https://ad.doubleclick.net/ddm/clk/416409958;217635604;p" target="_blank"><svg class="p-channel-banner-partner-logo"><use xlink:href="/sub-brand/assets/channels/hardfork/partner.svg#logo"></use></svg></a>
        </div>
        
        <!--
        <p class="p-channel-banner-tagline">News, announcement and insider stories for crypto traders</p>
        -->
    </div>
</div>
<div class="c-stream" id="stream">
    <article class="c-post js-post" data-post="1118548" data-index="1">
    
    <div class="u-wrapper">
                <div class="ad">
            <div class="ad-unit ad-unit--billboard" data-ad="TNW_DSKT_ARTL_BB"></div>
        </div>
                <header class="c-post-header">
                        <h1>Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed</h1>
                            <p class="c-post-subtitle">It has been more than 45 days since the bug was pointed out</p>
                        <div class="u-hideFrom-m">
                <ul class="c-shareIcons">
    <li><a class="c-shareIcons-icon c-shareIcons-icon--facebook" data-share-medium="facebook" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="https://tnw.to/D4fz8" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#facebook"></use></svg></a></li>
    <li><a class="c-shareIcons-icon c-shareIcons-icon--twitter" data-share-medium="twitter" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="https://tnw.to/BJNAf" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#twitter"></use></svg></a></li>
    <li><a class="c-shareIcons-icon c-shareIcons-icon--linkedin" data-share-medium="linkedin" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#linkedin"></use></svg></a></li>
    <li><a class="c-shareIcons-icon c-shareIcons-icon--mail" data-share-medium="mail" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#mail"></use></svg></a></li>
</ul>
            </div>
        </header>
        <div class="c-split">
            <main class="c-split-main">
                                <div class="u-wrapper-bleed">
                    <div class="c-post-image">
                        <img alt="ZCoin" data-lazy data-src="https://img-cdn.tnwcdn.com/image?fit=1280%2C720&url=https%3A%2F%2Fcdn0.tnwcdn.com%2Fwp-content%2Fblogs.dir%2F1%2Ffiles%2F2018%2F04%2FZCoin.png&expires=17291625950&signature=9ccbbb5bcf578679159e3e824035f0cc">
                        
                    </div>
                </div>
                                <div class="ad c-post-ad c-post-ad--top">
                    <div class="ad-unit ad-unit--rectangle" data-ad="TNW_MS_ARTL_MPU_ATF"></div>
                    <div class="ad-unit ad-unit--leaderboard" data-ad="TNW_DSKT_ARTL_LB_ATF"></div>
                </div>
                <div class="c-post-split">
                    <aside class="c-post-split-meta js-tnwSticky" data-sticky>
                        <div class="c-post-author">
                            <a href="https://thenextweb.com/author/neer-varshney" target="_blank" rel="noopener"><img alt="Neer Varshney" class="c-post-author-avatar" data-lazy data-src="https://img-cdn.tnwcdn.com/image/duotone?fit=240%2C240&gradient=%23660099-%2300CCAA&url=https%3A%2F%2Fsecure.gravatar.com%2Favatar%2Fa9f4ccfd7b77d30025d8fa05371b4488%3Fs%3D240%3Fs%3D240&expires=17291625950&signature=f789418d0a023a5b85addf3b8f6e7f0a"></a>
                            <h6>Story by</h6>
                            <h5><a href="https://thenextweb.com/author/neer-varshney" target="_blank" rel="noopener">Neer Varshney</a></h5>
                        </div>
                        <div class="c-post-split-sticky js-tnwSticky-content">
                            <ul class="c-post-engage">
    <li>
        <a class="c-post-engage-comments" data-comments-show href="#comments-1118548">
            <svg><use xlink:href="/sub-brand/assets/img/comments.svg#comments"></use></svg>
            <span data-comments-count></span>
        </a>
    </li>
            <li><a class="c-post-engage-share c-post-engage-share--facebook" data-share-medium="facebook" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="https://tnw.to/D4fz8" href="#" title="Share on Facebook"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#facebook"></use></svg></a></li>
                <li><a class="c-post-engage-share c-post-engage-share--twitter" data-share-medium="twitter" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="https://tnw.to/D4fz8" href="#" title="Share on Twitter"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#twitter"></use></svg></a></li>
                <li><a class="c-post-engage-share c-post-engage-share--linkedin" data-share-medium="linkedin" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="https://tnw.to/D4fz8" href="#"  title="Share on LinkedIn"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#linkedin"></use></svg></a></li>
        <li><a class="c-post-engage-share c-post-engage-share--mail" data-share-medium="mail" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="" href="#" title="Share via email"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#mail"></use></svg></a></li>
</ul>
                        </div>
                    </aside>
                    <div class="c-post-split-body">
                        <div class="c-post-readMore">
                            <div class="c-formatted c-post-content">
                                <p>Zerocoin has a ‘denial of service’ bug that allows for attackers to burn honest users’ coins. This fact has been known for almost two months now, but remains unfixed.</p>
<p>The problem was highlighted by <a href="https://twitter.com/real_or_random" target="_blank" rel="nofollow noopener">Tim Ruffing</a> in his presentation ‘<a href="https://youtu.be/eEgbuivlY64?t=37m29s" target="_blank" rel="nofollow noopener">A Tale of Zero Coins</a>‘ at the <a href="https://genesislondon.binarydistrict.com/" target="_blank" rel="nofollow noopener">Genesis Conference</a> in London in February.</p>
<p>Peter Todd tweeted in the aftermath that while ZCoin could prove that attackers can’t steal coins, but they couldn’t prove that attackers can’t destroy the coins they don’t own.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">"A Tale of Zero Coins" <a href="https://twitter.com/hashtag/genesislondon?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">#genesislondon</a></p>
<p>TIL the original Zerocoin protocol is broken, even though it was "proven secure". They proved an attacker couldn't steal coins, but they didn't prove the attacker couldn't destroy coins they didn't own.</p>
<p>— Peter Todd (@peterktodd) <a href="https://twitter.com/peterktodd/status/966678720160378886?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">February 22, 2018</a></p>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<p>A <a href="https://www.chaac.tf.fau.eu/2018/04/12/zerocoinzcoinpivxzoinsmartcashhexxcoin-attack/" target="_blank" rel="nofollow noopener">research work</a> published by four researchers in Germany including Ruffing, has now further proved this vulnerability.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">We found an attack on Zerocoin leading to vulnerabilities in the cryptocurrencies <a href="https://twitter.com/zcoinofficial?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@zcoinofficial</a>, <a href="https://twitter.com/zoinofficial?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@zoinofficial</a>, <a href="https://twitter.com/_pivx?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@_pivx</a> , <a href="https://twitter.com/scashofficial?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@scashofficial</a>, and <a href="https://twitter.com/hxxcoin?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@hxxcoin</a> (NOT Zcash); first two are still affected. Joint work with <a href="https://twitter.com/aravind2112?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@aravind2112</a>, Viktoria Ronge and <a href="https://twitter.com/doschroeder?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@doschroeder</a>.<a href="https://t.co/r3EYLxroNG" target="_blank" rel="nofollow noopener">https://t.co/r3EYLxroNG</a></p>
<p>— Tim Ruffing (@real_or_random) <a href="https://twitter.com/real_or_random/status/984419010711310337?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">April 12, 2018</a></p>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<p>The research paper shows how an attacker can force the network to reject an honest transaction as a ‘double-spend’:</p>
<blockquote>
<p>In both of the proposed Zerocoin schemes, a minted zerocoin is represented by a public bitstring, which is a commitment to the serial number but hides the serial number at the time of minting. Users are supposed to choose a random serial number to ensure that it is unique (with very high probability). However, an attacker can, instead of taking a new random serial number, freely choose the serial number when he mints a zerocoin.</p>
<p>This leads to the following attack: An honest user tries to spend her (honestly generated) zerocoin and sends the spend transaction (including the serial number) to the network. An attacker, which is assumed to have control over the victim’s network, now blocks that message such that it never reaches the nodes of the cryptocurrency. Then the attacker mints a new malicious zerocoin with the exact same serial number. The attacker can now spend this maliciously zerocoin, revealing the serial number.</p>
<p>As soon as this spend transaction performed by the attacker is confirmed, the nodes in the cryptocurrency network record this serial number as used. As a result, the honest user cannot spend her zerocoin anymore. Whenever she tries, her spend transaction will be rejected as a double-spend, because the serial number has already been recorded as used. This effectively burns the zerocoin of the honest user!</p>
</blockquote>
<p>ZCoin is based on the <a href="https://zcoin.io/wp-content/uploads/2016/11/zerocoinwhitepaper.pdf" target="_blank" rel="nofollow noopener">Zerocoin protocol</a> introduced by authors Ian Miers, Christina Garman, Matthew Green, Aviel D. Rubin at The Johns Hopkin University, although none of them are involved with the project themselves.</p>
<p>There are other cryptocurrencies based on the Zerocoin protocol, and they have all had the same vulnerability at some point — but only ZCoin and Zoin still remain vulnerable to the bug, the research says.</p>
<p>When this bug was pointed out in February, ZCoin had said that they are aware of the vulnerability and they have a fix ready that is in internal testing.</p>
<blockquote class="twitter-tweet" data-conversation="none" data-lang="en">
<p dir="ltr" lang="en">The vulnerability is known to us and a patch is ready and in internal testing. It was set to release yesterday but found some minor bugs. We have been working with <a href="https://twitter.com/real_or_random?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">@real_or_random</a> on this with our devs.</p>
<p>— Zcoin (@zcoinofficial) <a href="https://twitter.com/zcoinofficial/status/966855204502093825?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">February 23, 2018</a></p>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<p>The bug was apparently being fixed with the help of Tim Ruffing, who is one of the authors of the latest research that highlighted the bug. As per Ruffing, the contract with ZCoin had ended soon after they delivered the patches for some of the bugs that they were supposed to fix.</p>
<p>More than one month later though, the bug remains unfixed, and ZCoin is still saying that the bug is already fixed and the fix just needs to be activated on the network. This time they went a little far ahead, and tried to downplay the bug saying that the attack is very hard to pull off anyway.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Our official statement on the "denial-of-spend" Zerocoin attack. In short, the attack is very hard to pull off practically often leading to the attacker losing money, no new coins are created, &amp; the fix is already in place awaiting activation. <a href="https://twitter.com/search?q=%24XZC&amp;src=ctag&amp;ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">$XZC</a> <a href="https://twitter.com/hashtag/zcoin?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">#zcoin</a><a href="https://t.co/PUBeCm0Uz1" target="_blank" rel="nofollow noopener">https://t.co/PUBeCm0Uz1</a></p>
<p>— Zcoin (@zcoinofficial) <a href="https://twitter.com/zcoinofficial/status/984700871916191745?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">April 13, 2018</a></p>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<p>ZCoin has been running in trouble with technical glitches for a while. Another bug was discovered in February, when hackers managed to mint 370,000 coins out of nothing, Emin G Sirer, Cornell Professor, shared on Twitter.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Zerocoin gets hacked, hacker creates 370,000 coins out of thin air:  <a href="https://t.co/qjfonljwdT" target="_blank" rel="nofollow noopener">https://t.co/qjfonljwdT</a></p>
<p>— Emin Gün Sirer (@el33th4xor) <a href="https://twitter.com/el33th4xor/status/832750040615624704?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">February 18, 2017</a></p>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<p>Such continuous bug discovery and fixing episodes have prompted Matt Odell to conclude that altcoins are just a free market bug bounty program to help improve <a href="https://thenextweb.com/topic/bitcoin/" target="_blank" title="Read more about Bitcoin.">Bitcoin</a>.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Altcoins continue to be a testbed for future additions/changes to bitcoin.</p>
<p>A free market bug bounty program essentially. The best ideas will be merged into bitcoin. The failed ideas will be ignored. <a href="https://t.co/8a2iKPKhRe" target="_blank" rel="nofollow noopener">https://t.co/8a2iKPKhRe</a></p>
<p>— Matt Odell (@matt_odell) <a href="https://twitter.com/matt_odell/status/984430647963017217?ref_src=twsrc%5Etfw" target="_blank" rel="nofollow noopener">April 12, 2018</a></p>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<p> </p>
                            </div>
                                                        <div class="u-hideFrom-m">
                                <ul class="c-shareIcons">
    <li><a class="c-shareIcons-icon c-shareIcons-icon--facebook" data-share-medium="facebook" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="https://tnw.to/D4fz8" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#facebook"></use></svg></a></li>
    <li><a class="c-shareIcons-icon c-shareIcons-icon--twitter" data-share-medium="twitter" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="https://tnw.to/BJNAf" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#twitter"></use></svg></a></li>
    <li><a class="c-shareIcons-icon c-shareIcons-icon--linkedin" data-share-medium="linkedin" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#linkedin"></use></svg></a></li>
    <li><a class="c-shareIcons-icon c-shareIcons-icon--mail" data-share-medium="mail" data-share-title="Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed" data-share-url="" href="#"><svg viewBox="0 0 1 1"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="/sub-brand/assets/img/icons.svg#mail"></use></svg></a></li>
</ul>
                            </div>
                            <div class="c-post-comments" data-comments id="comments-1118548">
    <button class="c-post-comments-button button button--outline button--spinner" data-comments-show>
        <svg><use xlink:href="/sub-brand/assets/img/icons.svg#comments"></use></svg>
        Show <span data-comments-count data-comments-hide-none></span> comments
    </button>
    <script data-comments-html type="text/template">
        <div class="fb-comments" data-href="https://thenextweb.com/hardfork/2018/04/13/1118548" data-numposts="5"></div>
    </script>
</div>
                        </div>
                        <button class="c-post-readMore-button button button--outline" href="#">Read more</button>
                    </div>
                </div>
            </main>
            <aside class="c-split-sidebar js-tnwSticky" data-sticky>

                

                <div class="js-tnwSticky-content u-showFrom-l" style="top: 72px;">
                    <div class="ad c-post-ad c-post-ad--sidebar">
                        <div class="ad-unit ad-unit--rectangle" data-ad="TNW_DSKT_ARTL_MPU_ATF"></div>
                    </div>
                    <div class="c-recommended js-recommended">
        <h4>Most popular</h4>
                <a class="c-recommended-image" href="https://thenextweb.com/hardfork/2018/04/09/cryptocurrency-ads-facebook">
            <img alt="facebook" src="https://img-cdn.tnwcdn.com/image?fit=600%2C336&url=https%3A%2F%2Fcdn0.tnwcdn.com%2Fwp-content%2Fblogs.dir%2F1%2Ffiles%2F2018%2F04%2Ffacebook.png&expires=17291625950&signature=2cbc5687ac250cd12be0c9b3955337b7">
        </a>
                <div class="c-recommended-text">
            <h5><a class="p-channel-underline" href="https://thenextweb.com/hardfork/2018/04/09/cryptocurrency-ads-facebook">Cryptocurrency startups bypass Facebook ad ban with sly marketing tricks</a></h5>
        </div>
    </div>
                </div>
            </aside>
        </div>
    </div>
    <div class="ad c-post-ad c-post-ad--interstitial">
        <div class="ad-unit ad-unit--billboard" data-ad="TNW_DSKT_ARTL_BB_INFTSCR"></div>
    </div>
    <div class="ad c-post-ad c-post-ad--interstitial">
        <div class="ad-unit ad-unit--rectangle" data-ad="TNW_MS_ARTL_MPU_BTF"></div>
    </div>
</article>
</div>
            </div>
            <footer class="app-footer footer">
    <div class="u-wrapper">
        <div class="footer-split">
            <div class="footer-split-main">
                <div class="grid grid--collapse">
                    <div class="grid-col-xs-12 grid-col-l-6">
                        <div class="footer-branding">
                            <a href="/"><svg class="footer-branding-logo" preserveAspectRatio="xMidYMid meet" viewBox="0 0 66 16"><use xlink:href="/sub-brand/dist/img/icons.svg#tnw"></use></svg></a>
                            <p class="footer-branding-tagline">Remarkable progress&trade;</p>
                        </div>
                    </div>
                    <div class="grid-col-xs-6 grid-col-l-3">
                        <div class="footer-block">
                            <h5>More TNW</h5>
                            <ul class="footer-menu">
                                <li><a href="https://thenextweb.com/">News</a></li>
                                <li><a href="https://thenextweb.com/conference">Events</a></li>
                                <li><a href="https://thenextweb.com/x">Enterprise</a></li>
                                <li><a href="https://index.co/">Intelligence</a></li>
                                <li><a href="https://answers.thenextweb.com/">Answers</a></li>
                                <li><a href="https://tq.co/">Spaces</a></li>
                            </ul>
                        </div>
                    </div>
                    <div class="grid-col-xs-6 grid-col-l-3">
                        <div class="footer-block">
                            <h5>About TNW</h5>
                            <ul class="footer-menu">
                                <li><a href="https://thenextweb.com/about">About</a></li>
                                <li><a href="https://thenextweb.com/team">Team</a></li>
                                <li><a href="https://thenextweb.com/advertise">Advertise</a></li>
                                <li><a href="https://thenextweb.homerun.co/">Jobs</a></li>
                                <li><a href="https://thenextweb.com/contact">Contact</a></li>
                            </ul>
                        </div>
                    </div>
                </div>
            </div>
            <div class="footer-split-sidebar">
                <div class="footer-block">
                    <form action="hardfork/newsletter/subscribe" class="footer-subscribe" method="post" data-ajax>
                        <h5>Stay tuned</h5>
                        <input type="hidden" name="group" value="tnw">
                        <div class="footer-subscribe-success">
                            <p>Thank you!</p>
                        </div>
                        <div class="footer-subscribe-fields">
                            <ul class="footer-subscribe-list">
                                <li>
                                    <input checked id="list_weekly" name="list[weekly]" type="checkbox">
                                    <label for="list_weekly">Weekly</label>
                                </li>
                                <li>
                                    <input id="list_daily" name="list[daily]" type="checkbox">
                                    <label for="list_daily">Daily</label>
                                </li>
                                <li>
                                    <input id="list_breaking" name="list[breaking]" type="checkbox">
                                    <label for="list_breaking">Breaking</label>
                                </li>
                            </ul>
                            <div class="footer-subscribe-email">
                                <div class="form-inputWithIcon">
                                    <input class="form-input form-input--borderless" name="email" placeholder="Email" type="email" required>
                                    <svg><use xlink:href="/sub-brand/assets/img/icons.svg#mail"></use></svg>
                                </div>
                                <button type="submit">OK</button>
                            </div>
                        </div>
                    </form>
                    <ul class="footer-social">
                        <li><a class="button button--icon button--outline button--rounded" href="https://www.facebook.com/thenextweb" target="_blank" rel="noopener"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#facebook"></use></svg></a></li>
                        <li><a class="button button--icon button--outline button--rounded" href="https://twitter.com/thenextweb" target="_blank" rel="noopener"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#twitter"></use></svg></a></li>
                        <li><a class="button button--icon button--outline button--rounded" href="https://www.instagram.com/thenextweb" target="_blank" rel="noopener"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#instagram"></use></svg></a></li>
                        <li><a class="button button--icon button--outline button--rounded" href="https://www.youtube.com/thenextweb" target="_blank" rel="noopener"><svg><use xlink:href="/sub-brand/assets/img/icons.svg#youtube"></use></svg></a></li>
                    </ul>
                </div>
            </div>
        </div>
    </div>
    <div class="footer-legal">
        <div class="u-wrapper">
            <p>
                <span class="txt-nowrap">Copyright &copy; 2006&mdash;2018.</span>
                <span class="txt-nowrap">All rights reserved.</span>
                <span class="txt-nowrap">Made with <span class="footer-legal-heart">&hearts;</span> in Amsterdam.</span>
            </p>
        </div>
    </div>
</footer>
        </div>
        
        <div id="fb-root"></div>
<script>
    var adBlocker = false;

    var APP_ENV = {
        "permalink": "https://thenextweb.com/hardfork/2018/04/13/1118548",
        "paths":{
            "site": "//thenextweb.com/hardfork/",
            "base": "//thenextweb.com/hardfork/",
            "assets": "//thenextweb.com/hardfork/"
        },
        "pageIdx": 1,
        "currentPost": 1118548,
        "activePostIdx": 0,
                "postRack": [{"id":1118548,"permalink":"https:\/\/thenextweb.com\/hardfork\/2018\/04\/13\/1118548","category":"hardfork","title":"Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed","socialTitle":"Zerocoin&#8217;s bug that allows hackers to burn honest users&#8217; coins is still not fixed","socialDescription":"Zerocoin has a 'denial of service' bug that allows for attackers to burn honest users' Coins. This fact has been known for almost two months now, but remains unfixed.","datetime":"2018-04-13T14:24:38+00:00","author":"Neer Varshney","adTargeting":{"postId":1118548,"category":"hardfork","sponsorName":"","isSponsoredPost":"","isSponsoredCategory":""}}],
                "category": "hardfork",
        "adTargeting": {
            "postId": 1118548,
            "category": "hardfork",
            "sponsorName": null,
            "isSponsoredPost": "No",
            "isSponsoredCategory": "No"
        }
    };
</script>
<script src="//cdnjs.cloudflare.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
<script data-src="//connect.facebook.net/en_US/sdk.js#xfbml=1&amp;appId=378011798897423&amp;version=v2.6" id="socialSrcFacebook" type="text/template"></script>
<script data-src="//platform.twitter.com/widgets.js" id="socialSrcTwitter" type="text/template"></script>
<script src="/sub-brand//js/app.js?id=dd025246ff49be557a2c"></script>
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/81489/tag"></script>
    </body>
</html>
